Confuser supports plugins, so you can write plugin to implement different protections. Please note that most of the time the plugins isn't updated with the latest version of Confuser, so you might need to patch it or recompile it from the source.

Plugins:

Last edited Oct 26, 2013 at 10:50 AM by yck1509, version 5