Error: Cannot resolve ...

Apr 29, 2013 at 8:54 AM
Hello,

first, thank you for this awesome software.
Confuser is great and working well with my assemblies.
However, one of them crashes Confuser with

System.Exception
Message : Cannot resolve 'mscorlib, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'!

because my assembly is using a 3rd party assembly which has a static reference to mscorlib Version 1.0.3300.0 and on my computer there is no such Version installed.

I managed to get around this error by defining a Confuser.exe.config with the following lines:
<?xml version="1.0"?>
<configuration>
    <startup useLegacyV2RuntimeActivationPolicy="true">
        <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0"/>
    </startup>
</configuration>

But now I get

System.Exception
Message : Cannot resolve 'System.Windows.Forms, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'!

How do I get around this?

Thank you.
Coordinator
May 9, 2013 at 12:04 PM
I guess your assembly is targeted .NET 1.0, which is very out-dated and not supported by Confuser.