Confuser crash ( System.ArgumentException)

Aug 16, 2012 at 3:17 PM
Edited Aug 16, 2012 at 3:23 PM

Hello,

I'm trying to obfuscate a console application, i'm gettting an error ( an element with the same key was already added) V1.9

Here is process trace.

 

Started at 16:08.
Loading...
Loading assemblies...



Oops... Confuser crushed...

System.ArgumentException
Message : Un element avec la meme cle a deja ete ajoute.
Stack Trace :
   a System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
   a System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)
   a System.Collections.Generic.Dictionary`2.Add(TKey key, TValue value)
   a Confuser.Core.Marker.Initalize(IList`1 cions, IList`1 packs) dans C:\Documents and Settings\Administrateur\Bureau\confuser-76271\Confuser.Core\Marker.New.cs:ligne 162
   a Confuser.Core.Confuser.Initialize() dans C:\Documents and Settings\Administrateur\Bureau\confuser-76271\Confuser.Core\Confuser.cs:ligne 452
   a Confuser.Core.Confuser.Confuse(ConfuserParameter param) dans C:\Documents and Settings\Administrateur\Bureau\confuser-76271\Confuser.Core\Confuser.cs:ligne 240

Please report it!!!

 

Please can anyone help me.

Thanks

Coordinator
Aug 17, 2012 at 6:42 AM

Hi,

If you don't mind, please send your original files and *.crproj file to confuser.net@gmail.com. Your files will be kept secret and deleted after I fix this issue.

Aug 17, 2012 at 10:07 AM
Edited Aug 17, 2012 at 10:26 AM

Hi
thanks for your quick response.
I Just  send you an example project along with configuration file.

Aug 17, 2012 at 10:33 AM

Problem Solved.

I used to add the plugin Confuser.Core.dll . I deleted it from plugin list and now it works.
thanks.