Confuser is a protector/obfuscator for .NET, providing great security to .NET Applications.

Confuser is not being actively maintained. Please use the successor ConfuserEx instead!

Features:
  • Anti debugger
  • Anti memory dumping
  • Anti decompiler
  • Prevent any tampering of the assemblies
  • Encrypt codes
  • Encrypt constants (i.e. numbers & strings)
  • Encrypt resources
  • Control flow obfuscation
  • External/Internal reference proxy
  • Renaming

If for some reasons you're still using Confuser, and you got problems with it, try:
  1. Use the latest build at https://confuser.codeplex.com/releases/view/101015
  2. Ensure all dependencies are put in the same directory
  3. Use a lesser preset, like Aggressive/Normal
  4. Silverlight and WinRT are not supported, you may have luck getting it work but it is not guaranteed.
Thank you for your interest!

Screenshots!!!
1
1
3
4
5
6
7

Sponsored by NDepend!

Last edited May 28 at 5:52 AM by yck1509, version 11